View Issue Details

IDProjectCategoryView StatusLast Update
0000134BwPostmanNewsletters Backendpublic2020-07-30 16:13
Reporterdstreichert Assigned ToRomana  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.3 
Target Version3.0Fixed in Version2.4 
Summary0000134: If gzip is activated in Joomla, the error message "Content Encoding Error" is displayed when sending a newsletter.
DescriptionIf gzip is activated in Joomla, the error message "Content Encoding Error" is displayed when sending a newsletter in version 2.3.1.
The newsletter is sent normally, but the error message is displayed and the Javascript can of course not be executed, since it did not arrive in the browser.
For example, a solution in version 2.3.1 would be:
In the file "/administrator/components/com_bwpostman/views/newsletter/view.raw.php" delete lines 169 and 170 and in the file "/administrator/components/com_bwpostman/models/newsletter.php" lines 2364, 2365 , 2642 and 2643.
TagsNo tags attached.

Activities

dstreichert

2020-03-18 17:49

reporter  

view.raw.php.diff (768 bytes)   
--- view.raw.orig.php	2020-03-14 12:12:40.000000000 +0100
+++ view.raw.php	2020-03-18 17:17:50.000000000 +0100
@@ -165,10 +165,8 @@
 				{   // No more mails to send.
 					// reset number of queue entries before start sending
 					$app->setUserState('com_bwpostman.newsletters.entries', null);
 					echo '<div id="nl_modal_to_send_message">' . JText::_('COM_BWPOSTMAN_NL_QUEUE_COMPLETED') . "</div>";
-					ob_flush();
-					flush();
 					echo '<script type="text/javascript">' . "\n";
 					// We cannot replace the "&" with an "&amp;" because it's JavaScript and not HTML
 					echo "function goBackToQueue(){window.parent.location.href = 'index.php?option=com_bwpostman&view=newsletters&layout=queue';} \n";
 					echo "setTimeout('goBackToQueue()',5000); \n";
view.raw.php.diff (768 bytes)   
newsletter.php.diff (628 bytes)   
--- newsletter.orig.php	2020-03-14 12:12:37.000000000 +0100
+++ newsletter.php	2020-03-18 17:17:00.000000000 +0100
@@ -2360,10 +2360,8 @@
 		try
 		{
 			$sendMailCounter = 0;
 			echo JText::_('COM_BWPOSTMAN_NL_SENDING_PROCESS');
-			ob_flush();
-			flush();
 
 			while(1)
 			{
 				$ret = $this->sendMail($fromComponent);
@@ -2638,10 +2636,8 @@
 		if ($fromComponent)
 		{
 			echo "\n<br>{$tblSendMailQueue->recipient} (" .
 				JText::_('COM_BWPOSTMAN_NL_ERROR_SENDING_TRIAL') . ($tblSendMailQueue->trial + 1) . ") ... ";
-			ob_flush();
-			flush();
 		}
 
 		// Get a JMail instance
 		$mailer		= JFactory::getMailer();
newsletter.php.diff (628 bytes)   

Issue History

Date Modified Username Field Change
2020-03-18 17:49 dstreichert New Issue
2020-03-18 17:49 dstreichert File Added: view.raw.php.diff
2020-03-18 17:49 dstreichert File Added: newsletter.php.diff
2020-04-15 07:40 Romana Assigned To => Romana
2020-04-15 07:40 Romana Status new => assigned
2020-04-15 07:41 Romana Fixed in Version => 2.4
2020-04-15 07:41 Romana Target Version => 2.4
2020-06-09 15:37 Romana Status assigned => resolved
2020-06-09 15:37 Romana Resolution open => fixed
2020-07-30 16:13 Romana Target Version 2.4 => 3.0